NewCelica.org Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
8,097 Posts
Discussion Starter · #1 ·
I thought these werent supposed to leak like APC's do?? That is the whole reason I got these unless by some chance you all think that something is causing them to leak got any ideas???? I need your help, what should I do with them???

Justin
 

·
Registered
Joined
·
8,097 Posts
Discussion Starter · #4 ·
Well I bought them used so, which the seller said they didn't have any condensation when they were on his car, he sent me pics and they didn't look like they had any in them when he took pics nor did I see any signs of them having condensation in them when I recieved them!! I really trust the dude I bought them from so I was thinking that maybe its just some way I installed them wrong or something!! Whats even more weird is that I have had them on for several weeks have washed my car at least 5 times since I put them on and it just started like today!! So maybe it has somethig to do with the rubber seals behind them or something. When I washed my car I noticed water running down behind the chrome stuff lining the outside of the tail but water never actually got into the tail light but now it is actually in the light so I am lost. I really dont think it is the seal though cause I have heard of people putting their TYC's in without a seal at all and even they didnt have trouble with them leaking!! Any ideas at all though would be most helpful and thanks for your time!!

Justin
 

·
Registered
Joined
·
1,757 Posts
I did...I had a little condensation when I washed mine...probably the rubber seal is gone on the back? Take them out and see...maybe reseal it..
 

·
Registered
Joined
·
8,097 Posts
Discussion Starter · #10 ·
Damn them bastards well guess I am going to break out the clear silicone man I don't think it is the rubber seal but seems to be leaking around wherethe chrome trim stuff is, somehwer around in there!! I guess I will be forced to do like Mistrimeat said and silicone them!! :( I hope I can run a small enough bead that no one will notice!! I also think it only happens when I wash my car also!! I dunno but I got to fix it that crap bugs the hell out of me!! Thanks for the replies guys and I will let u all know how it goes!! Thanks again!!

Justin
 

·
Registered
Joined
·
803 Posts
mines dont leak out. they used to fog up a little but i think i solved that problem. make sure you use the cushion piece and lock in all the bulbs. i used extra tape to make sure there was no opening gaps between the bulbs.
 

·
Registered
Joined
·
1,925 Posts
the chrome strip around the lamp is actually starting to chip off from the moisture getting in...I tried calling TYC and they gave me the run around time and time again...i have to admit they are just about the worst company I have ever dealt with. I checked all the foam seals and they are fine..I guess I will have to crack mine open and reseal them somehow :(
 

·
Registered
Joined
·
2,899 Posts
DAAANNNGGG.....i walked outside the other morning and noticed for the first time that my driver side (original version with crap fit) had fogged up in the turn signal area. i figured that it would go away as the day got warmer, but it didn't. now, i'm sending it back to the place i got it and they are sending me a new one for free. bless TYC's lifetime warranty. anyways, i've heard that the fitment problem seemed fixed to some people, so we'll see what happens when i get this new one.
 

·
Registered
Joined
·
161 Posts
I think you need to call up and b*tch, make sure you tell them that you'll report them to the better business bureau and the warrenty board for their lack of support on their products. It won't be wise to silicone it before you bitch at them because that will give them an excuse to void your warrenty.
 

·
Registered
Joined
·
1,233 Posts
ya mine fog up to...damn bastards i did everything to make it work too....pisses me off but nothing u can do but get new ones, so **** it. peace
 

·
Registered
Joined
·
8,097 Posts
Discussion Starter · #18 ·
Damn them bastards LOL!!!! I am def. going to complain about this even if it doesn't get me any new ones or anything, I will still tell the better business bureau and so forth! Hey at least I didn't pay near $200 for mine like some have LOL!! I got mine for $85 so it didn't set me out that bad!! Thank God!!

Justin
 
1 - 18 of 18 Posts
Top