NewCelica.org Forum banner

1 - 20 of 54 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Okay. I've been reading these forums for a while now but never posted because my questions were always answered using the Search. It wasn't until I bought the Greddy S/C that I became a member, because I knew something was going to go wrong after reading about other owners' experiences.

Man, was I right! First, I received my kit with a LOCKED S/C. No kidding... I could not even budge the S/C rotors to spin by hand. I returned that part and Greddy sent a replacement. While waiting for the part though, I encountered the emanage threads, so I decided to hook up my emanage before attempting to install the rest of the kit. The wiring was already set... I just never tested it because I never got past the S/C part. So, everything was put back together as stock except left the emanage wiring in tacked.

I hook up the emanage and the car would not start. I unplug the emanage and the car starts without a hiccup. I get the solid green light and I checked for the loose chip... Intacked.

It has been a very frustrating time with Greddy, because they made THREE attempts to repair my emanage before I finally wrote a letter, stating their online warranty policy on defective products. It worked, and I finally got a new "boxed & untuned" emanage Ultimate. I asked for a fresh one with software, considering what I went through and I got a base and tuned map from Jlitman.

I followed the instructions and exported Jlitman's map to the emanage. I turn the key, and guess what? The car still did not start. :furious: I swear that I went upstairs in an attempt to grab the rest of the kit and throw it in the dumpster. I bought mine from the first batch, and I STILL don't have this working yet. What stopped me is that I am not sure I have the Jumper settings right. I used Search and found settings for JP 7, JP 10, JP15-17, JP 19-20, and set for hot-wire airflow input, 12V. Can anyone tell me the rest of the numbers or or the order of the correct settings? I saw some other threads with the same unanswered questions. Maybe someone can open up their pretuned emanage Ultimate and post the settings.

It may not be my settings at all, but if anyone has any other ideas, your input is greatly appreciated.

~BigMo
 

·
Registered
Joined
·
1,350 Posts
does it turn over?? and make sure the wiring is correct and that the emanage is grouned right.. and the wiring diagram they provide with the kit has some color mix ups
 

·
Registered
Joined
·
1,268 Posts
damn, everyone and there families are having problems with this kit........
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
VladsGTS said:
does it turn over?? and make sure the wiring is correct and that the emanage is grouned right.. and the wiring diagram they provide with the kit has some color mix ups
It turns over. It feels like it's so close to starting right up, and I press a little gas but nothing happens. I can smell the fuel.

My buddy was soldering the wires with me, and we each had a copy of the diagram to confirm colors. I even went as far as placing tape on the wire tips and wrote which ecu wire to solder to before attempting the install.
 

·
Registered
Joined
·
1,950 Posts
Blitz s/c +1!!

j/k.

I'm sure you can get all the support here. All these guys been through trial and error so don't just give up yet. I'm pretty sure someone here will help you out.

Good luck and keep us posted.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #7 ·
Black_TRD said:
do you have the kit's injectors installed?
No, I do not have the kit's injectors installed. I thought it was possible to check that it worked before attempting anything else. I can do that though. Do you think that much fuel was restricted with the stock injectors?
 

·
Registered
Joined
·
1,350 Posts
similar thing happend to me when trying to start a car up that was just supecharged and we forgot to ground the emanage, when we did it started right up.. just install the supercharger and everything that came with it .. then try starting it.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #9 ·
I will attempt to install everything next week then. I would just hate to finish the install and not find the same unsolved problem. Maybe it's the grounding that I'm not understanding. How do you ground the emanage correctly, VladsGTS?
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #10 ·
I thought ground was to splice emanage B-24 wire into Stock ECU wire B-17.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #12 ·
Okay, this sucks. I finally managed to complete the install today after a month delay due to hectic work schedule. The emanage still won
 

·
Registered
Joined
·
726 Posts
damn this sucks... seems like everyone that has the greddy has probs with it. hope you get that thing workin... good luck.... btw, if someone had their greddy sc installed at a shop, wouldnt the most likely get it right without all these probs?
 

·
Registered
Joined
·
1,365 Posts
damn dude, that really sucks, and the sad part is that you still not even stressing with the tunning yet.

but this is the last thread i deal with about this, im going to take mine out and start messing with it. im in north cal, got any good tuner shops? or you doing the install yourself?
 

·
Banned
Joined
·
227 Posts
with the greddy emanage ultimate having incorrect wiring diagrams, broken ecu parts, faulty basemaps, and restricted tunability i got the apexi pfc. the install is simple, unplug & plug and i won't have to deal with the piggyback ecu's problems.

only problem with going the pfc route is no basemap. just gotta wait for a fellow member to share their basemap or monkeywrench to tune one. hopefully patience will pay off...
 

·
Premium Member
Joined
·
12,227 Posts
when you Greddy S/C folks realize, get a freaking PFC!!!! the emanage sucks
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #19 ·
Well, the car has to sit in the garage for a few days since I have to fly to New York tomorrow. I'm just going to find a shop nearby that knows about this stuff and make an appointment upon my return.
 

·
Registered
Joined
·
1,561 Posts
BigMo said:
Well, the car has to sit in the garage for a few days since I have to fly to New York tomorrow. I'm just going to find a shop nearby that knows about this stuff and make an appointment upon my return.
If you are gonna be in New York, let me know bro, send me a pm and I can show you how my S/C install looks like and see if you get any ideas, you can also see my wiring. I have the feeling that the emanage is not working properly, what else is new. With the help of Boosted 2.0, Milesplume and East Coast Speed Factory I was able to get the car running in decent condition, no CEL's and the power is there. I'm still not 100% tuned, it sucks not having good tunners on the east coast, at this point I'm thinking about bringing the car to Florida or to Boosted's home town Houston, TX and get it tune right once for all. Good luck bro.
 
1 - 20 of 54 Posts
Top