NewCelica.org Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter · #1 · (Edited)
Well I went to the dyno today to find out why my car has been running VERY lean lately.

I pulled three runs

One baseline

One with new plugs

One with new Plugs and Disty cap

I netted some damn good numbers but my car was running VERY lean as indicated by my A/F gauge and the dyno proved the A/F gauge reading to be correct.

I had a problem with my FP regualtor, I did not figure it out util I got home, pissed trying to figure out why my car had been running so lean lately. When I first installed the SC it ran rich, too rich actually, now it was the opposite, with nothing done to the car since.

I thought the dyno would help me figure it out.

Well after I got home from the dyno I decided to do a FP check. I had set the Fuel pressure to 45psi at WOT a while ago, but for some reason when I hooked up my FP gauge it only read [email protected]!!! Holy ****.

Somehow the screw got loose and over time and bumpy roads the screw had unwinded, resulting a a very low FP.

So I re-set the FP back up to [email protected] and the car feels MUCH better now.

If it was'nt for the 12:1 FMU my engine would be toast right now.

now my A/F gauge reads in the green and my car feels and runs much happier, just smooth acceleration.

I only pushing 6 psi.

Im sure that just with the Fuel issues resolved I gained a good 10hp and 10lb TQ.

How does almost 300HP to the crank sound???? heheehheahahh



My car weighs 2600 lbs with ME in it.
 

·
Registered
Joined
·
2,839 Posts
pic doesn't work mike... what were the numbers? i wanna look at the shape of the curve...
R
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #3 · (Edited)
pic works now...sorry

252hp to the wheels

247tq to the wheels

I know it's a lil shkay but thats was due to the very low fuel pressure.


Damn, at only 3500rpm I am putting 150tq to the wheels and at 4000rpm I am putting 175 to the wheels!

As you can see the SC hit peak TQ at around 5200 rpm which is a bit lower than I expected but the HP climbs like a MOFO to almost 7000rpm

keep in mind that I have done NO tuning except bolting on the SC
 

·
Registered
Joined
·
2,839 Posts
the torque curve seems to fall abruptly right after peak... i wonder if you are holding boost all the way to redline...
R
 

·
Registered
Joined
·
2,839 Posts
the 3SGTE is on hold again... the suspected oil leak wasn't coming from the oil return line from the turbo, so i need to determine where it's coming from now... and having the motor all taken apart with oil spilled everywhere doesn't really help either...
R
 

·
Registered
Joined
·
393 Posts
nice numb ers mike......bring that to florida and run it!!
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #8 ·
the torque curve seems to fall abruptly right after peak... i wonder if you are holding boost all the way to redline...
R


The tq drops off so quickly after peak because I was running out of fuel, the fuel pressure was too low to compensate for the added spark and the car started to bog out thus losing boost.


I have since resolved the fuel issue and I got some higher flowing injectors to drop in on the way. I should be able to push close to 10lbs with the higher flow injectors along with my high flow fuel pump. Should be another 20-30hp to the wheels EASY

I have since done some recent G-tech passes ( no tracks open yet) but my trap speed on the gtech has gone from 108mph to 114mph) 1/4 times are just a bit quicker (12.7's) but Im not testing 1/4 mile ET's just traps because the ground is too cold to try and lauch with 240lbs of tq to the front wheels good lord!
 
1 - 8 of 8 Posts
Top