NewCelica.org Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
today i was driving and i had a loss of power and alot of white smoke comming oout of my exhaust. then finally the car shut off and i couldnt start it again. i pushed it to the side of the road and sat for about 10 minutes, then it started again and still bogged all the way home. my check engine light is on also. i thought it might be the head gasket or i got water into my sprak plug because its raining here and my hood has holes in it. any help would be helpful.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #2
this is my second motor my other one my piston barrings went out and toyota had to replace it.
 

·
Registered
Joined
·
209 Posts
It really sounds like a head problem, when coolant leaks into the combustion chamber the result is usually large clouds of white smoke. What have you been doing to your car to drop two engines?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
the first engine it starved for oil and the piston barrings went out. this one i took the turbo off about 2 weeks ago and my check engine light started showing.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
i jacked my car up, i pulled my filter off my cai and it was soaked, and in the intake tubing there was alot of water and where the throttle body is there was water. imma change my oil and filter and let the car sit for a while, hopefully that will help. i dont have a spark plug adapter to see if it got to my spark plug though..
 
1 - 5 of 5 Posts
Top