NewCelica.org Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
well here i am sinking a **** load more money into my ride... here is my current problem i was doing about 140 down the freeway and went from 5th to 3rd and watched the rpms go it was only a second but i really thin the lifters are bent and the oil pump is jacked, it has a REALLY rough unsteady idle it drives fine when driveing until i hit lift then the clutch stays stuck in and i have to stomp on it a couple time for it to come back out....now here is my qeustios

1. Does any one have any idea what could be the clutch issue?
2. does any one besides prodrive make an aftermarket oilpump
3. what are my options for a complete upgraded head unit
4. and the really big one can some one please tell me were to find a
sequetial shifter set-up for a 2000 celica gt-s
5. oh yeah and does any one have a phone number for Prodrive thanks


:worthless
 

·
Zettai Unmei Mokushiroku
Joined
·
28,865 Posts
1. Most likely broken pressure plate.
2. Not that I know of.
3. Shouldn't you be looking to fix your engine instead of upgrading your stereo? :chuckles: JK, check MonkeyWrenchRacing.com.
4. The MR2 Spyder has one, but it pretty much sux (no launching, slow shifts). Just learn how to drive better. ;)
5. Not I.
 

·
Registered
Joined
·
11,645 Posts
why the hell were you going 140? and why the hell did you downshift?
 

·
Registered
Joined
·
2,319 Posts
akplayboy2001 said:
...then the clutch stays stuck in and i have to stomp on it a couple time for it to come back out...
1. Does any one have any idea what could be the clutch issue?
When I overeved mine I sheared all of the flywheel bolts and bent the strap things that are around the outside of the cover plate. It also damaged some of the holes in the flywheel where the bolts used to be

dB
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #6 ·
lol i was pissed at my girl ( hence 140) wasnt paying attention (hence the stupid shift mistake) was trying to slow down for and exit that i was coming up on to fast was braking and down shifting but shifted to wrong gear. screw the stereo lol i know i know.. well i hope it a flywheel cause ive been lookin to put in my new one....im just prayin its not in the engine ill know thursday when toyota get done with it
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #9 ·
how much you lookin for it? besides its shipping that kills me....im in alaska
 
1 - 10 of 10 Posts
Top